【PCルータ】 Vyatta

1login:Penguin2010/10/22(金) 17:27:38ID:tnj4oKpw
VPNやUTM機能を備えたDebianベースのルータ用ディストリビューションVyattaについて語るスレです。

公式サイト
http://www.vyatta.com/

PCルータ特化OSまとめwiki
http://www.esc-j.net/pc-router/index.php?Vyatta

380login:Penguin2015/02/08(日) 22:12:49.55ID:J5av+30O
リモートアクセス経由で入ってきた通信をルータのデフォルトルートとは別の場所に飛ばしたいんだけど、うまく出来てる人いる?

接続時にl2tp0ってインターフェースができるみたいなんだけど、そのインターフェースにはpolicyが適用できないっぽい。

381login:Penguin2015/02/11(水) 22:59:34.75ID:Nv+UJhdd
>>380
できないよ

382login:Penguin2015/05/05(火) 23:10:09.41ID:8EdODAHN
*.v4flets-east.jpの名前解決を、フレッツのサービス情報サイトの
DNSサーバーにforwardしたいときってどう書けばいいのかな。
pppoeはつながってるし、サービス情報サイトだけの接続なら
問題ないんだけど、インターネットと同時につなげようとすると
名前解決がうまくいかないんだよね。

eth0 pppoe0 インターネット
eth0 pppoe1 サービス情報サイトNGN IPv4
eth1 LAN
eth2 使ってない

protocols {
static {
interface-route 123.107.190.0/24 {
next-hop-interface pppoe1 {
}
}
interface-route 220.210.194.0/25 {
next-hop-interface pppoe1 {
}
}
}
}
dns {
forwarding {
cache-size 0
listen-on eth1
listen-on eth2
options "server=/*.v4flets-east.jp/123.107.190.5"
options "server=/*.v4flets-east.jp/123.107.190.6"
}
}

383login:Penguin2015/05/06(水) 08:32:14.99ID:X2wCCPME
>>5
オープンソース界隈じゃもう、rerdhat系なんてメジャーじゃないよ。
Debian一色。

当然Centなんて論外だし、Fedoraもどんどん規模が小さくなってる。

384login:Penguin2015/05/06(水) 08:33:48.52ID:ZFHVLG1T
>>382
dnsmasq.confの文法でいうと*.が邪魔なんじゃないでしょうか。
ttp://www.thekelleys.org.uk/dnsmasq/docs/dnsmasq-man.html
-S, --local, --server=[/[<domain>]/[domain/]][<ipaddr>[#<port>][@<source-ip>|<interface>[#<port>]]
if you have a nameserver on your network which deals with names of the form xxx.internal.thekelleys.org.uk
at 192.168.1.1 then giving the flag -S /internal.thekelleys.org.uk/192.168.1.1 will send all queries for
internal machines to that nameserver, everything else will go to the servers in /etc/resolv.conf.
ソースインタフェース指定もできるんですね。

385login:Penguin2015/05/06(水) 12:55:46.88ID:UvZAgEjL
>>384
ありがとうございます。
エラーメッセージが出てこないのが痛いな…

どうもHGWのPPPoEブリッジを経由すると、2つめのセッションが
うまくつながらないようです。ISPかサービス情報サイトの片方だけなら
問題なくつながります。
HGWを通さなければちゃんと2つともつながるんですけどね

386login:Penguin2015/05/06(水) 13:24:47.50ID:UvZAgEjL
http://feasible-lab.com/cisco%E3%83%9E
この例だとサービス情報サイトのDNSサーバー(123.107.190.5,
123.107.190.6)をコンフィグに書いて、ISPのDNSサーバーは
ppp ipcp dns request accept
で取得するという目論見のようだけどうまく動くのかな

Vyattaだとこのコマンドになるかな
set system name-server 123.107.190.5
set system name-server 123.107.190.6
set interfaces ethernet eth0 pppoe 1 name-server auto

Vyattaだとこのドメインルーティングには対応してないよね?
https://flets.com/customer/next/square/setup/v4/win7.html

387login:Penguin2015/05/06(水) 15:52:02.33ID:M4P8V9vy
>>384のアドバイスの通りやってみたらできました!
IEからはアクセスできてChromeからはダメだったので
ChromeのDNSキャッシュを消した
http://d.hatena.ne.jp/killinsun/20131128/1385609793
のですが、それでもダメで ipconfig /flushdns でつながりました。

ありがとうございました。

388login:Penguin2015/05/06(水) 16:28:20.36ID:M4P8V9vy
今のところこういう設定です
http://txt.do/goz2

389login:Penguin2015/05/07(木) 00:23:47.47ID:8E0Oezrm
これは後続の人の役に立ちそうですね

390login:Penguin2015/05/07(木) 01:14:15.36ID:ZACIdAGJ
dns multiple forwarders の設定、以前悩んでた。
今のvyatta本家は知らないけど、派生系バージョンは微妙にコマンドが違ってる。

VyOS 1.1.5 (helium)
set service dns forwarding name-server '8.8.8.8'
set service dns forwarding domain flets server '123.107.190.6'

EdgeOS(v1.6.0)
set service dns forwarding name-server '8.8.8.8'
set service dns forwarding options 'server=/flets/123.107.190.6'

どちらもcommit後の /etc/dnsmasq.conf には以下のように展開
server=8.8.8.8
server=/flets/123.107.190.6

391login:Penguin2015/05/07(木) 01:22:57.03ID:VEHAaWUJ
ぐぐったらこのサイトが出てきて、この設定だと
サービス情報サイトの名前解決ができなさそうなんだけど
http://d.hatena.ne.jp/pekeq/20100803/p1

もう少し補足すると、*.v4flets-east.jpの他に*.fletsも入れてあげた方がいいみたい
options server=/v4flets-east.jp/flets/123.107.190.5
options server=/v4flets-east.jp/flets/123.107.190.6

今のところの問題は、フレッツ速度測定(IPv4)で速度測定ができない。
firewallがらみかと思ったけど違うみたいだし、様子を見てみます

392login:Penguin2015/05/07(木) 01:37:59.55ID:ZACIdAGJ
追加: pppoe1が、フレッツ情報サイトとして、static-routing追加

set protocols static interface-route 123.107.190.0/24 next-hop-interface pppoe1 distance '1'
set protocols static interface-route 220.210.194.0/25 next-hop-interface pppoe1 distance '1'
set protocols static interface-route 220.210.198.0/26 next-hop-interface pppoe1 distance '1'


>>391
まとめて書かずに、行分けないとダメ
options server=/v4flets-east.jp/123.107.190.5
options server=/flets/123.107.190.5

393login:Penguin2015/05/07(木) 01:56:50.47ID:VEHAaWUJ
>>392
-S, --local, --server=[/[<domain>]/[domain/]][<ipaddr>[#<port>][@<source-ip>|<interface>[#<port>]]
複数書けるようになってるけど、確かに読みにくいね

DNSサーバーのIPアドレスじゃなくてpppoe1のネームサーバーって
指定はできないのかな

今はこうなってて、*.fletsも*.v4flets-east.jpも名前解決はできてる

dnsmasq.conf
#
# autogenerated by vyatta-dns-forwarding.pl on Wed May 6 17:47:12 JST 2015
#
log-facility=/var/log/dnsmasq.log
interface=eth1
interface=eth2
cache-size=150
server=/v4flets-east.jp/flets/123.107.190.5
server=/v4flets-east.jp/flets/123.107.190.6

resolv.conf
nameserver 123.107.190.5 # nameserver added by pppoe1
nameserver 123.107.190.6 # nameserver added by pppoe1
nameserver xxx.xxx.xx.xx # nameserver added by pppoe0
nameserver xxx.xxx.xx.xx # nameserver added by pppoe0

394login:Penguin2015/05/12(火) 13:51:39.25ID:PkO/oyDe
TCPのMSS調整の
set policy route PPPOE-IN rule 10 destination address '0.0.0.0/0'
指定ってdestination 指定なしとどう違うの?

395login:Penguin2015/05/13(水) 00:22:50.21ID:fscPGEx+
一緒。あったほうが分かりいいからかな。
将来 destination address '!192.168.0.0/16' みたいに
除外条件つけたくなるときのヒントにもなるかもだし。

396login:Penguin2015/05/13(水) 23:45:57.10ID:3fVfapKg
>>395
なるほどそういうことなのか。ありがとう

397login:Penguin2015/05/21(木) 22:40:11.48ID:Civtw8Bj
vyosで、pppoe server 作りたいと思ったんですが、機能ないんですね。
git上ではソースはあるようですがパッケージでの提供はないようです。

自分でbuildしないとダメなんですかね?

398login:Penguin2015/05/22(金) 20:21:56.98ID:TIhYuUjj
大谷が指回したら塁審もスイング取るしかないよな

399login:Penguin2015/05/22(金) 20:23:23.69ID:TIhYuUjj
スーパー誤爆ったね

4003972015/06/01(月) 01:13:57.27ID:V6xJpLKO
今の最新ソース(lithium)を、gitから持ってきて make iso したら動いた。
しかしベースが debian squeeze なのね。古すぎるなー

401login:Penguin2015/06/02(火) 00:42:27.61ID:KvnySfIT
そんな事言う奴がなぜVyOSでPPPoEサーバをやろうと思ったのかが疑問

4023972015/06/02(火) 22:31:16.14ID:86VeNH30
テスト用のpppoeサーバーを立てるのに、楽しようと思ってvyosに当たりつけたのがスタート。
結局rp-pppoeですませたけど、vyosのビルドも気になっていたので、やってみたので報告まで

403sage2015/06/23(火) 19:43:57.76ID:Z+mLaoZy
VyOSにpppoe設定をいれて、ルータを作成したのですが一部のサイト(yahooとか色々)が見れなかったりしております。
体感的に7割のサイトが見れて、3割のサイトが見れない感じです。
mtu,mru,mss 関係の部分でVyOSが悪さをしているという記述を見つけて色々と試したのですが未だに見れません。

>>249
のような設定をいれたり
下記URLの設定をいれたりしてみたのですが
ttp://mikeda.hatenablog.com/entry/20121217/1355762337

症状が改善されません。

使用しているOSは
最新の安定版: VyOS 1.1.5 (Helium) を使用しているのですが同様の症状が出ている方いらっしゃいませんか?

解決策をご存知の方いらっしゃいましたらアドバイス頂けませんでしょうか?

404login:Penguin2015/07/12(日) 22:38:25.48ID:0Is+3/eO
まだ見てるかな? pppoe に、mss いじる設定入れる

set policy route mss-clamp rule 10 destination address '0.0.0.0/0'
set policy route mss-clamp rule 10 protocol 'tcp'
set policy route mss-clamp rule 10 set tcp-mss '1414'
set policy route mss-clamp rule 10 tcp flags 'SYN'
set interfaces ethernet eth0 pppoe 0 mtu '1454'
set interfaces ethernet eth0 pppoe 0 policy route 'mss-clamp'

mtu/mssは環境に応じて、微調整してね。

405login:Penguin2015/07/15(水) 08:54:49.55ID:7FkY/RZP
>>368
この人の問題、解決できたのかな?
同じような構成でハマってるので解決策聞きたい。

406login:Penguin2015/07/15(水) 12:18:27.47ID:He86obyc
outsideをローカルアドレス、idとremote-idを設定してみりゃどうね?とテキトーなコトを同じく詰まってるバカが申し上げてみる。

407login:Penguin2015/08/13(木) 19:33:34.66ID:o6M9KjFJ
VyOS1.1.5で
>http://wiki.vyos-users.jp/%E3%82%88%E3%81%8F%E3%81%82%E3%82%8B%E8%B3%AA%E5%95%8F%28FAQ%29
の通りにリポジトリ設定して
apt-get update
apt-get upgrade
から再起動するとSSHキーが見つからないみたいなエラーが出るんだけどもこれは一体

408login:Penguin2015/08/13(木) 21:20:35.58ID:c8mh9u0+
そもそも何でapt-get upgradeなんてしようと思ったの?

409login:Penguin2015/08/14(金) 12:47:39.69ID:JrDDxIVJ
vyos 1.05 amd64でなら、無線atherosの最新ドライバ入れたかったり、sambaでファイルサーバーとかしたかったりとかあったんでやったことあるよ。
環境はatom D510だったんでVTなしKVMつかえない実機。
ネットで探した方法で、ほぼ出来ました。
ちなみにvmware fusion上の1.15でもテストを兼ねてやってみたけどapt-get upgradeするとvyosの設定が保存されないとかあり、苦労しそうだったんでさっさと諦めました。

410login:Penguin2015/08/15(土) 14:47:54.66ID:ZjxqkeGJ
>>409
設定保存されないのか
怖いな

411login:Penguin2015/08/15(土) 15:33:31.76ID:6ZKqZE4S
公式に「apt-get upgradeすんな、リスキーでんねん」ってあるんだから、トラブル解消できないならやるなよ。

412login:Penguin2015/08/22(土) 10:29:49.66ID:FZU1RWO9
1.2.0が来たかと思ったら1.1.6だった

413login:Penguin2015/08/22(土) 20:31:23.08ID:lqG2e47Q
USBキーボード指してると起動しないね
機種によるんだろうけど

414login:Penguin2015/12/31(木) 13:24:02.91ID:DVNsqqwR
まだ生きてるかな?

vyosでIPv6ブリッジ(パススルー)をやりたいのですがやり方がわかりません。
ブリッジかけてFWでIPv4フィルタかけてもARPが出てしまいます。
他にいいやり方ありませんか?

415login:Penguin2015/12/31(木) 19:19:17.83ID:hg08hUOe
>>414
firewallがiptablesベースなので難しいと思う.そのうちebtablesベースにするとかvyattaの頃から言われてた気がするけど.

以前IPv4ルーター,IPv6ブリッジをしたかった時はvyatta諦めてseil x86使ったので上手く動く方法あれば知りたい.

416login:Penguin2016/01/01(金) 14:52:00.90ID:CNFZ0pFJ
やっぱりそうかありがとう
SEIL/x86は買ってあるからそっちを使うか

417login:Penguin2016/11/18(金) 05:02:14.05ID:n1+FJryk
ローカルIPでISPの振り分けをしたく思っています

set nat source rule 10 outbound-interface pppoe0
set nat source rule 10 source address 192.168.0.10/32
set nat source rule 10 translation address masquerade
ここで192.168.0.10はpppoe0を使ってネット接続出来ています

set nat source rule 20 outbound-interface pppoe1
set nat source rule 20 source address 192.168.0.11/32
set nat source rule 20 translation address masquerade
これを付け加えると192.168.0.11はpppoe1を使ってネット接続出来るのですが
192.168.0.10が接続できなくなってしまいます

多分何か根本的な間違いがあると思うのですがどなたか教えていただけないでしょうか

418login:Penguin2017/01/10(火) 04:20:54.43ID:RyL6C+5F
まさかとは思うが二つの NAT 設定を一つの interface に適用してるだけなんじゃ。
一つの interface に複数の PPPoE セッションを通す事は可能らしいので、譬えば

set interfaces ethernet eth1 address '192.168.0.10/32'
set interfaces ethernet eth2 address '192.168.0.11/32'

となってるなら出来るはずでは。NAT 設定は IP で指定しているが、
実際は interface 毎に適用されるもの。そして各内部 interface は
通常は複数の機器に繋がるので、通常 NAT+DHCP を設定してサブネットをきる。

/32 だと無意味。そもそもサブネットを別にしているので、
最初から eth1: 192.168.0.0/24, eth2: 192.168.1.0/24 とかにすればいいのに。

419login:Penguin2017/02/05(日) 20:12:26.51ID:7NhtlCM/

420login:Penguin2017/02/13(月) 20:47:28.39ID:LlvPhB+k
同一interface内でのISP振り分けは>>29みたいなのしかないような

421login:Penguin2017/02/28(火) 07:16:23.21ID:ctZr9jwr
root@vyos:~# vi /etc/ssh/sshd_config
で修正した設定がリブートしたら消えるんだけどどうしたらいい?
UseDNS yes → UseDNS no に変更したいんだけど

422login:Penguin2017/02/28(火) 18:22:50.17ID:Me4vJdRm
再起動で消えるなら保存してないんじゃ

423login:Penguin2017/03/02(木) 00:50:26.24ID:wfHai9jx
編集前の該当行は1行のみで
UseDNS yes

コピペして編集
#UseDNS yes
UseDNS no

リブートすると
#UseDNS yes
UseDNS yes

コメントアウトした行は残ってるから何者かがno→yesに書き換えてる感じです

424login:Penguin2017/05/25(木) 13:56:07.26ID:eQZ4DO0Z
VyOSの開発版入れてみたけどcofigに互換性無いのか設定そのまま移行すると動かんな

425login:Penguin2017/05/28(日) 11:32:19.89ID:IxmJ+Yc4
>>424
結構書式変わるらしいですね

426login:Penguin2017/12/27(水) 06:05:58.54ID:1Yacw4ru
VyOS1.1.8出てるの気付かなかった

427login:Penguin2017/12/29(金) 15:32:51.74ID:S/CsVkMC
誰でも簡単にパソコン1台で稼げる方法など
参考までに、
⇒ 『宮本のゴウリエセレレ』 というブログで見ることができるらしいです。

グーグル検索⇒『宮本のゴウリエセレレ』

EUDXE4DATF

428login:Penguin2018/02/15(木) 01:15:43.34ID:m3isa15O
☆ 現在、衆議員と参議院の両院で、改憲議員が3分の2を超えて
おります。総務省の、『憲法改正国民投票法』、でググってみてください。
国会の発議はすでに可能です。日本の、改憲を行いましょう。
平和は勝ち取るものです。お願い致します。☆☆

429login:Penguin2018/05/22(火) 09:56:44.82ID:Czl6p0FW
僕の知り合いの知り合いができた副業情報ドットコム
関心がある人だけ見てください。
グーグルで検索するといいかも『ネットで稼ぐ方法 モニアレフヌノ』

WED5V

430login:Penguin2018/09/05(水) 14:12:29.97ID:Mv8v9Z5b
VyOSってDHCPv6-PDに対応してる?

新着レスの表示
レスを投稿する